Upgrade from 1.9 to 2.0

From Proxmox VE
Jump to: navigation, search

Contents

Introduction

There are two possibilities to move from 1.9 to 2.0 (and any 2.x):

  • New installation on new hardware (and restore VM´s from backup), recommended way.
  • In-place upgrade via upgrade script

In-place upgrade from 1.9 to 2.0 is a demanding task, but we provide an upgrade script to simplify this. You can use the script to update a 1.9 default installation to 2.0. Upgrades should only be done on non-modified systems (default ISO installs), and from experienced admins. Please read http://www.debian.org/releases/stable/amd64/release-notes/ch-upgrading.html to get an idea on what needs to be done.

Note: Make sure your hardware and your network meets the requirements for 2.0 (See Proxmox_VE_2.0_Cluster)! If you want to run a cluster, make sure that your network support IP multicast, especially in hosting environment this is not always the case.

New installation on new hardware

If possible, install 2.0 on new servers and move your VM´s step by step via backup/restore. If you choose this method you can do the move step by step and with minimum risk.

In-place upgrade via script

Before you start, make sure you have a valid backup of all your settings, VM´s and CT´s. If the upgrade fails, you should be able to do a clean ISO installations and restore all VM´s and CT´s from backup.

We provide an upgrade script which does the following:

  • Remove Proxmox VE 1.9 packages (save old configs)
  • Dist-upgrade from Lenny to Squeeze
  • Installation of Proxmox VE 2.1
  • Import most old settings
  • Purge obsolete packages

Requirements

  • Up2date Proxmox VE 1.9
  • Running 2.6.32 kernel
  • Backup of all VM´s and CT´s
  • No running VM´s or CT´s
  • Enough free space in your /root filesystem

Start the upgrade

  • make sure you have up to date 1.9 system with kernel 2.6.32 running
  • Login to your Proxmox VE host with SSH and download the script:
wget http://download.proxmox.com/debian/dists/squeeze/pve/pve-upgrade-1.9-to-2.0
  • make the script executable:
chmod +x pve-upgrade-1.9-to-2.0
  • Stop all your VMs and Containers
  • Execute the script.
./pve-upgrade-1.9-to-2.0

Depending on your Internet connection and hardware the upgrade will take some time (if everything is fast it will take about 10 minutes). The script is idempotent, so you can safely restart it if something goes wrong.

./pve-upgrade-1.9-to-2.0

The script writes a detailed log to 'pve-upgrade.log', and moves old configuration to:

/etc/qemu-server ==> /etc/qemu-server.old-1.9
/etc/pve ==> /etc/pve.old-1.9
/etc/vz/conf ==> /etc/vz/conf.old-1.9
  • Reboot. Consider running 'upgrade-from-grub-legacy' if boot works without problems.
  • Cluster configuration: if you run a cluster, you need to configure or join the cluster now (see Cluster below)
  • Import old setting (VM´s and CT´s)
./pve-upgrade-1.9-to-2.0 --import
  • Check system, see first steps with 2.0
  • Purge obsolete packages to save disk space (optional, use with care and only if you did not installed optional packages)
./pve-upgrade-1.9-to-2.0 --purge

Cluster upgrades

The new cluster architecture is completely different to the 1.9 version, so the upgrade script is unable to upgrade that automatically. That means, after successful upgrade of all nodes, you need to build the new cluster, see Proxmox_VE_2.0_Cluster. After you joined all nodes you can start the import of VM´s and CT´s. So you need to execute the following steps

  • upgrade all node using the upgrade script
  • configure the new cluster, see Proxmox_VE_2.0_Cluster.
  • run "./pve-upgrade-1.9-to-2.0 --import" on the old master node
  • run "./pve-upgrade-1.9-to-2.0 --import" on all other nodes

Troubleshooting

Grub2 install problems

If your host does not boot due to wrong grub2 upgrade, try to recover by booting form a live-cd, e.g.You can try to fix your grub2 config use the Super Grub2 Disk

Just boot with the supergrub2 cd and select "Detect any GRUB2 configuration file (grub.cfg)"

This should boot your Proxmox VE system. As soon as you got Proxmox VE booted, run 'upgrade-from-grub-legacy' again, selecting the right boot disk - in my example its /dev/sda.

External links

Release Notes for Debian GNU/Linux 6.0 (squeeze), 64-bit PC

Personal tools
Namespaces

Variants
Actions
Navigation
Virtual Appliances
Sites
Tools