Difference between revisions of "Developer Workstations with Proxmox VE and X11"

From Proxmox VE
Jump to: navigation, search
(Install Mate Desktop)
(NVidia Drivers)
 
(17 intermediate revisions by 3 users not shown)
Line 7: Line 7:
 
Just install the standard Proxmox VE, following this guide: [[Installation]]
 
Just install the standard Proxmox VE, following this guide: [[Installation]]
  
Custom installations: [[Install Proxmox VE on Debian Wheezy]]
+
Custom installations: [[Install Proxmox VE on Debian Buster]]
  
 
== Install X-windows ==
 
== Install X-windows ==
  
 
Update your repository and system by running:
 
Update your repository and system by running:
  aptitude update && aptitude full-upgrade
+
  apt-get update && apt-get dist-upgrade
  
 
I choose xfce4 desktop as this a lightweight desktop environment. If you prefer another one, just replace xfce4 with lxde, gnome, icewm, kde, ...
 
I choose xfce4 desktop as this a lightweight desktop environment. If you prefer another one, just replace xfce4 with lxde, gnome, icewm, kde, ...
  
  aptitude install xfce4 chromium lightdm
+
  apt-get install xfce4 chromium lightdm
  
 
== Start X-windows ==
 
== Start X-windows ==
Line 25: Line 25:
 
Start the login manager:
 
Start the login manager:
  
  service lightdm start
+
  systemctl start lightdm
  
 
or just reboot.
 
or just reboot.
  
== Install Oracle Java Browser Plugin ==
+
== Optional: Linux Mint Mate Desktop ==
To install Oracle Java, see [[Java_Console_(Ubuntu)]]
+
Install  Proxmox VE as described above.
  
We recommend to install Google Chrome browser, as iceweasel on Squeeze is too outdated.
+
install from Debian repository.
 +
apt-get install mate
  
== Optional: Linux Mint Mate Desktop ==
+
== Optional: NVidia Drivers ==
[[Install Proxmox VE on Debian Jessie]] did not work, 2015.12.17.
+
# tested proxmox 5.3
  
Install Proxmox ve 4.2 as described above.
+
  # nouveau was faulting system. blacklist or unload driver
 +
# lspci -k |grep VGA
 +
# add 0000: to unbind driver.
 +
# echo "0000:24:00.0" > /sys/bus/pci/drivers/nouveau/unbind
  
I will reinstall and test the following section by 2015.12.18.
+
# blacklist
=== Update Apt Sources List===
+
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
  
  echo "deb http://www.deb-multimedia.org jessie main non-free" >>/etc/apt/sources.list.d/mint.list
+
# /etc/apt/sources.list
  echo "deb http://packages.linuxmint.com betsy main" >>/etc/apt/sources.list.d/mint.list
+
# PVE pve-no-subscription repository provided by proxmox.com,
  echo "deb http://extra.linuxmint.com betsy main" >>/etc/apt/sources.list.d/mint.list
+
# NOT recommended for production use
 +
# deb http://download.proxmox.com/debian/pve stretch pve-no-subscription
  
  
=== Add  Keyring===
 
Run the following one at a time
 
  
  apt-get update
 
  apt-get install deb-multimedia-keyring
 
  apt-get install linuxmint-keyring
 
  apt-get install debian-archive-keyring
 
  apt-get update
 
  apt-get dist-upgrade
 
  
=== Install Mate Desktop ===
+
# enable non-free
 +
cat <<EOF >>/etc/apt/sources.list
 +
deb http://deb.debian.org/debian stretch main contrib non-free
 +
deb-src http://deb.debian.org/debian stretch main contrib non-free
 +
 +
deb http://deb.debian.org/debian-security/ stretch/updates main contrib non-free
 +
deb-src http://deb.debian.org/debian-security/ stretch/updates main contrib non-free
 +
 +
deb http://deb.debian.org/debian stretch-updates main contrib non-free
 +
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free
 +
EOF
 +
 
 +
 
 +
# install the headers and nvidia-drivers
 +
apt install pve-headers
 +
apt-get update
 +
apt-get install  nvidia-driver
  
  apt-get install mate-desktop-environment xorg lightdm
 
 
  # apt-get install mint-backgrounds-debian
 
  # apt-get install X11vnc
 
  # reboot?
 
  
  
  
 
[[Category: HOWTO]][[Category: Installation]]
 
[[Category: HOWTO]][[Category: Installation]]

Latest revision as of 21:46, 7 December 2019

Introduction

Proxmox VE is primarily used as virtualization platform with NO additional software installed. In some case it makes sense to have a full desktop running on Proxmox VE, for example for developers using Proxmox VE as their primary workstation/desktop.

Installing additional packages could lead to a hardly upgradeable system and is not supported from the Proxmox support team and therefore only for expert use.

Install a standard Proxmox VE system

Just install the standard Proxmox VE, following this guide: Installation

Custom installations: Install Proxmox VE on Debian Buster

Install X-windows

Update your repository and system by running:

apt-get update && apt-get dist-upgrade

I choose xfce4 desktop as this a lightweight desktop environment. If you prefer another one, just replace xfce4 with lxde, gnome, icewm, kde, ...

apt-get install xfce4 chromium lightdm

Start X-windows

Before starting the x-windows, create a normal user with:

# adduser newusername

Start the login manager:

systemctl start lightdm

or just reboot.

Optional: Linux Mint Mate Desktop

Install Proxmox VE as described above.

install from Debian repository.

apt-get install mate

Optional: NVidia Drivers

# tested proxmox 5.3
# nouveau was faulting system. blacklist or unload driver 
# lspci -k |grep VGA
# add 0000: to unbind driver.
# echo "0000:24:00.0" > /sys/bus/pci/drivers/nouveau/unbind
# blacklist 
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
# /etc/apt/sources.list
# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
# deb http://download.proxmox.com/debian/pve stretch pve-no-subscription



# enable non-free
cat <<EOF >>/etc/apt/sources.list
deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ stretch/updates main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free
EOF


# install the headers and nvidia-drivers
apt install pve-headers
apt-get update 
apt-get install  nvidia-driver