Difference between revisions of "Guest Boot Problems"

From Proxmox VE
Jump to navigation Jump to search
(Created page with "Category:Troubleshooting When a guest fails to start, the GUI doesn't present you with an immediate error. Below are some steps you can try: * SSH into the Proxmox VE server…")
 
 
(4 intermediate revisions by 2 users not shown)
Line 3: Line 3:
  
 
* SSH into the Proxmox VE server.
 
* SSH into the Proxmox VE server.
* Review the contents of <code>vzctl.log</code>:
+
== KVM ==
 +
* Review the contents of <code>syslog</code>:
 
<pre>
 
<pre>
tail -50 /var/log/vzctl.log
+
tail -50 /var/log/syslog
 +
 
 
</pre>
 
</pre>
* Try starting the VM from the shell (change VMID to the guest VM's ID number):
+
* Try starting the VM from the shell. This should reveal problems that are preventing the VM from booting.
 +
** '''Note:''' Change VMID to the guest VM's ID number:
 
<pre>
 
<pre>
 
qm start VMID
 
qm start VMID
 
</pre>
 
</pre>
 +
 +
The last step noted above made me aware that an ISO I was using for the VM's CD drive was missing. The ISO had been deleted some how. Here's the output of the command from my server:
 +
 +
<pre>
 +
vm3:/storage/template/iso# qm start 104
 +
volume 'local:iso/clonezilla-live-1.2.6-24-i686.iso' does not exist
 +
</pre>
 +
 +
== LXC ==
 +
 +
See [[Linux_Container#_managing_containers_with_tt_span_class_monospaced_pct_span_tt|Linux_Container]]
 +
paragraph "Obtaining Debugging Logs".

Latest revision as of 15:16, 28 November 2016

When a guest fails to start, the GUI doesn't present you with an immediate error. Below are some steps you can try:

  • SSH into the Proxmox VE server.

KVM

  • Review the contents of syslog:
tail -50 /var/log/syslog

  • Try starting the VM from the shell. This should reveal problems that are preventing the VM from booting.
    • Note: Change VMID to the guest VM's ID number:
qm start VMID

The last step noted above made me aware that an ISO I was using for the VM's CD drive was missing. The ISO had been deleted some how. Here's the output of the command from my server:

vm3:/storage/template/iso# qm start 104
volume 'local:iso/clonezilla-live-1.2.6-24-i686.iso' does not exist

LXC

See Linux_Container paragraph "Obtaining Debugging Logs".