[pve-devel] kernel 2.6.32-14 : vlan over bonding don't work

Alexandre DERUMIER aderumier at odiso.com
Mon Aug 20 16:48:14 CEST 2012


Thanks, 

I'll try to correct the kernel first.

Redhat seem to have done (too much?) cleanup in bonding code in rhel 6.3 kernel.

6 month ago, tagging over bridge doesn't work.

But if I remember, I have tried mixing tagged and non tagged vlans without any problem.
(this is why you have done your patch, right ?)
Which pve kernel do have tried ?




----- Mail original ----- 

De: "Jason Villalta" <jason at rubixnet.com> 
À: "Alexandre DERUMIER" <aderumier at odiso.com> 
Cc: pve-devel at pve.proxmox.com 
Envoyé: Lundi 20 Août 2012 16:10:13 
Objet: Re: [pve-devel] kernel 2.6.32-14 : vlan over bonding don't work 

You should try this patch, it moves the vlan to the bridge and off of the bond. 


http://forum.proxmox.com/threads/10110-New-network-configuration-with-bridge-vlan-interfaces?s=c574f92e59b7d7f59c7ee977eeb7a699&p=57321#post57321 



On Mon, Aug 20, 2012 at 10:05 AM, Alexandre DERUMIER < aderumier at odiso.com > wrote: 


Hi, 
I'm testing kernel 2.6.32-14, 
and I'm having network bug with vlan over bonding. (network don't work) 
Tested with broadcom card (bnx2) driver. 

I'm not sure it's a driver bug, It's works fine If I remove bond. 

I see a bug report in the forum here. 

http://forum.proxmox.com/threads/10635-2-6-32-14-causing-bonding-and-or-vlan-issues 


I'll try to debug it. 
_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 






-- 

-- 



	

Alexandre D e rumier 

Ingénieur Systèmes et Réseaux 


Fixe : 03 20 68 88 85 

Fax : 03 20 68 90 88 


45 Bvd du Général Leclerc 59100 Roubaix 
12 rue Marivaux 75002 Paris 



More information about the pve-devel mailing list