[pve-devel] [PATCH 2/3] use scsi-generic by default with libiscsi

Alexandre DERUMIER aderumier at odiso.com
Wed Aug 29 09:34:13 CEST 2012


scsi-block should be used with scsi,open-iscsi devices /dev/sd.. for passthrough
http://repo.or.cz/w/qemu.git/commit/336a6915bc7089fb20fea4ba99972ad9a97c5f52

I don't think that scsi-generic can handle passthrough with block device

now scsi-generic vs scsi-hd, I really don't know. (need benchmark ?)

scsi-generic was not live migratable before february 2012.
http://repo.or.cz/w/qemu.git/commit/56b1fc48233499a395827a7f370429a989f5dc86

(so maybe it's not yet feature complete)


Maybe qemu-dev are trying to make scsi-generic working for all the cases and replace all other type in a near future  ?



----- Mail original ----- 

De: "Dietmar Maurer" <dietmar at proxmox.com> 
À: "Alexandre DERUMIER" <aderumier at odiso.com>, pve-devel at pve.proxmox.com 
Envoyé: Mercredi 29 Août 2012 09:10:15 
Objet: RE: [pve-devel] [PATCH 2/3] use scsi-generic by default with libiscsi 

But why can't we use scsi-generic for other scsi devices? 

> -----Original Message----- 
> From: Alexandre DERUMIER [mailto:aderumier at odiso.com] 
> Sent: Mittwoch, 29. August 2012 08:12 
> To: Dietmar Maurer 
> Cc: pve-devel at pve.proxmox.com 
> Subject: Re: [pve-devel] [PATCH 2/3] use scsi-generic by default with libiscsi 
> 
> 
> because passthrough is enable with scsi-generic + libiscsi 
> http://lists.gnu.org/archive/html/qemu-devel/2012-04/msg04139.html 
> 
> 
> Can't tell for scsi-block, but stefan have had a discussion about it with qemu 
> devels. 



-- 

-- 



	

Alexandre D e rumier 

Ingénieur Systèmes et Réseaux 


Fixe : 03 20 68 88 85 

Fax : 03 20 68 90 88 


45 Bvd du Général Leclerc 59100 Roubaix 
12 rue Marivaux 75002 Paris 


More information about the pve-devel mailing list