[pve-devel] KVM with same cores as host is as slow as one core

Stefan Priebe - Profihost AG s.priebe at profihost.ag
Fri Jul 19 10:53:11 CEST 2013


Hi,

Am 19.07.2013 09:22, schrieb Alexandre DERUMIER:
> What are the physical processors ? (Is it an numa architecture ? if yes, could be a memory bandwith problem)
> 
> Do you have tried to launch unixbench on the host to compare ?
> 
> 
> Maybe can you try to add +x2apic cpu flag ? It should reduce interrupts. (It's already in current qemu-server git)

Sorry ignore me. This seems to be a known bug:
https://code.google.com/p/byte-unixbench/issues/detail?id=4

Stefan

> ----- Mail original ----- 
> 
> De: "Stefan Priebe - Profihost AG" <s.priebe at profihost.ag> 
> À: pve-devel at pve.proxmox.com 
> Envoyé: Vendredi 19 Juillet 2013 09:07:27 
> Objet: [pve-devel] KVM with same cores as host is as slow as one core 
> 
> Hi, 
> 
> while benchmarking my kvm machines using unixbench i see the following 
> reproducable behaviour. 
> 
> Host has 24 cores. 
> 
> KVM Machine set to 2 cores: Unixbench Value 2514 
> KVM Machine set to 16 cores: Unixbench Value 6714 
> KVM Machine set to 24 cores: Unixbench Value 1742 
> 
> Also i see a max of 105% CPU Usage of the KVM process when setting the 
> cores to 24. 
> 
> While i'm seeing more than 1000% setting it to 16 cores. 
> 
> Stefan 
> _______________________________________________ 
> pve-devel mailing list 
> pve-devel at pve.proxmox.com 
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 
> 


More information about the pve-devel mailing list