[pve-devel] [PATCH] enforce cpu check

Alexandre DERUMIER aderumier at odiso.com
Thu Apr 3 09:31:19 CEST 2014


Ok,I have done test with 2.6.32 host kernel, I have the same error than you.

So I think we can remove the patch for now, and maybe reapply it with 3.10 will be the proxmox default kernel.

Really sorry about this :(



----- Mail original ----- 

De: "Alexandre DERUMIER" <aderumier at odiso.com> 
À: "Dietmar Maurer" <dietmar at proxmox.com> 
Cc: pve-devel at pve.proxmox.com 
Envoyé: Jeudi 3 Avril 2014 09:21:57 
Objet: Re: [pve-devel] [PATCH] enforce cpu check 

I see that kvm_asyncpf (and other kvm_xxxf flags) is a new qemu cpu flag in qemu 1.7 

qemu 1.4 

kvm -cpu ? 
Recognized CPUID flags: 
pbe ia64 tm ht ss sse2 sse fxsr mmx acpi ds clflush pn pse36 pat cmov mca pge mtrr sep apic cx8 mce pae msr tsc pse de vme fpu 
hypervisor rdrand f16c avx osxsave xsave aes tsc-deadline popcnt movbe x2apic sse4.2|sse4_2 sse4.1|sse4_1 dca pcid pdcm xtpr cx16 fma cid ssse3 tm2 est smx vmx ds_cpl monitor dtes64 pclmulqdq|pclmuldq pni|sse3 
3dnow 3dnowext lm|i64 rdtscp pdpe1gb fxsr_opt|ffxsr mmxext nx|xd syscall 
perfctr_nb perfctr_core topoext tbm nodeid_msr tce fma4 lwp wdt skinit xop ibs osvw 3dnowprefetch misalignsse sse4a abm cr8legacy extapic svm cmp_legacy lahf_lm 


qemu 1.7 

pbe ia64 tm ht ss sse2 sse fxsr mmx acpi ds clflush pn pse36 pat cmov mca pge mtrr sep apic cx8 mce pae msr tsc pse de vme fpu 
hypervisor rdrand f16c avx osxsave xsave aes tsc-deadline popcnt movbe x2apic sse4.2|sse4_2 sse4.1|sse4_1 dca pcid pdcm xtpr cx16 fma cid ssse3 tm2 est smx vmx ds_cpl monitor dtes64 pclmulqdq|pclmuldq pni|sse3 
smap adx rdseed rtm invpcid erms bmi2 smep avx2 hle bmi1 fsgsbase 
3dnow 3dnowext lm|i64 rdtscp pdpe1gb fxsr_opt|ffxsr mmxext nx|xd syscall 
perfctr_nb perfctr_core topoext tbm nodeid_msr tce fma4 lwp wdt skinit xop ibs osvw 3dnowprefetch misalignsse sse4a abm cr8legacy extapic svm cmp_legacy lahf_lm 
pmm-en pmm phe-en phe ace2-en ace2 xcrypt-en xcrypt xstore-en xstore 
kvm_pv_unhalt kvm_pv_eoi kvm_steal_time kvm_asyncpf kvmclock kvm_mmu kvm_nopiodelay kvmclock >> here 
pfthreshold pause_filter decodeassists flushbyasid vmcb_clean tsc_scale nrip_save svm_lock lbrv npt 



Seem that they should be filtered, but it's not the case. 
I have done test with 3.10 kernel without problem (xeon and opteron servers), maybe it's a bug in kvm module in 2.6.32, not filtering the flags 
I'll do test with 2.6.32 host kernel. 



----- Mail original ----- 

De: "Alexandre DERUMIER" <aderumier at odiso.com> 
À: "Dietmar Maurer" <dietmar at proxmox.com> 
Cc: pve-devel at pve.proxmox.com 
Envoyé: Jeudi 3 Avril 2014 09:08:15 
Objet: Re: [pve-devel] [PATCH] enforce cpu check 

this is strange, kvm64 should be compatible with all processor. 

I'll check on redhat bugzilla, because AFAIK, they will enable enforce by default for rhev/ovirt. 



----- Mail original ----- 

De: "Dietmar Maurer" <dietmar at proxmox.com> 
À: "Daniel Hunsaker" <danhunsaker at gmail.com> 
Cc: "Alexandre DERUMIER" <aderumier at odiso.com>, pve-devel at pve.proxmox.com 
Envoyé: Jeudi 3 Avril 2014 07:21:39 
Objet: RE: [pve-devel] [PATCH] enforce cpu check 

> Looks like the default "kvm64" CPU isn't based on the Xeon feature set 
> (probably based on an AMD processor). That is, I don't see a processor type 
> in your config... 

We cannot include a patch that breaks VMs using default configuration. 
So is it possible to fix that, or should I remove the patch? 
_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 
_______________________________________________ 
pve-devel mailing list 
pve-devel at pve.proxmox.com 
http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel 


More information about the pve-devel mailing list