[pve-devel] first recompiling from source

Paul Penev ppquant at gmail.com
Mon Apr 14 18:41:21 CEST 2014


I'm trying to compile master on a wheezy install, but I'm encountering
problems with dependencies.

It looks like some of the packages are dependent on a proxmox kernel
2.6.32-pve-19 which is not obtainable.

Other packages (like pve-qemu-kvm) require a spice library which is
not available in wheezy:

 dpkg-checkbuilddeps: Unmet build dependencies: libspice-protocol-dev
(>= 0.12.5)

Shall I move to debian testing for proxmox compilation ?
If so, how do I use compiled packages back into proxmox 3.2 when
dependencies are not met.

Is there a release tag or a branch that is compatible with current
proxmox stable version ?

thanks.


More information about the pve-devel mailing list