[pve-devel] first recompiling from source

Dietmar Maurer dietmar at proxmox.com
Tue Apr 15 06:24:40 CEST 2014


> It looks like some of the packages are dependent on a proxmox kernel
> 2.6.32-pve-19 which is not obtainable.

If you really want to compile that package yourself, you need to change that dependency to
a more recent kernel header.

> Other packages (like pve-qemu-kvm) require a spice library which is not available
> in wheezy:
> 
>  dpkg-checkbuilddeps: Unmet build dependencies: libspice-protocol-dev (>=
> 0.12.5)
> 
> Shall I move to debian testing for proxmox compilation ?
> If so, how do I use compiled packages back into proxmox 3.2 when
> dependencies are not met.

The git repository contains sources for those missing pieces.

https://git.proxmox.com/?p=pve-spice-protocol.git;a=summary




More information about the pve-devel mailing list