[pve-devel] [PATCH] ips : allow --queue-bypass only for kernel 3.10

Alexandre Derumier aderumier at odiso.com
Tue Apr 15 07:25:21 CEST 2014


This don't exist in 2.6.32 kernel

Signed-off-by: Alexandre Derumier <aderumier at odiso.com>
---
 src/PVE/Firewall.pm |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/PVE/Firewall.pm b/src/PVE/Firewall.pm
index 8c8e50a..400adba 100644
--- a/src/PVE/Firewall.pm
+++ b/src/PVE/Firewall.pm
@@ -1503,7 +1503,7 @@ sub generate_nfqueue {
 		$action .= " --queue-num $1";
 	    }
 	}
-	$action .= " --queue-bypass";
+	$action .= " --queue-bypass" if $feature_ipset_nomatch; #need kernel 3.10
     }else{
 	$action = "ACCEPT";
     }
-- 
1.7.10.4



More information about the pve-devel mailing list