[pve-devel] try to build kernel pve-kernel-2.6.32 :

Alexandre DERUMIER aderumier at odiso.com
Wed Apr 23 16:22:54 CEST 2014


since this commit, I can't build anymore the pve-kernel-2.6.32, because of gcc version check

https://git.proxmox.com/?p=pve-kernel-2.6.32.git;a=blobdiff;f=Makefile;h=be071832b199843df48c25d7cf7b2f78d1a52c2d;hp=df41ff1e2eee26a7186f4852c3eab390a82d573b;hb=8c149a1c92328a32e84958bcba3dd50d273aadb0;hpb=96dee95d30179f4df5381412021d1798044ac209 


-       gcc --version|grep "4.7.2" || false
+       gcc --version|grep "4.4.7" || false




# gcc --version
gcc-4.7.real (Debian 4.7.2-5) 4.7.2
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


# dpkg -l|grep gcc
ii  gcc                                   4:4.7.2-1                          amd64        GNU C compiler
ii  gcc-4.4                               4.4.7-2                            amd64        GNU C compiler
ii  gcc-4.4-base:amd64                    4.4.7-2                            amd64        GCC, the GNU Compiler Collection (base package)
ii  gcc-4.7                               4.7.2-5                            amd64        GNU C compiler
ii  gcc-4.7-base:amd64                    4.7.2-5                            amd64        GCC, the GNU Compiler Collection (base package)
ii  libgcc1:amd64                         1:4.7.2-5                          amd64        GCC support library


any idea ?


More information about the pve-devel mailing list