[pve-devel] [PATCH v4 0/3] fix migration related issues

Thomas Lamprecht t.lamprecht at proxmox.com
Thu Jun 2 14:44:56 CEST 2016


Same as previous but try to keep backwards compatibility for live migrating VMs
from nodes with an old unupgradeable qemu-server to a new one.
Also addressed some bad style in the first patch, although I'm not quite happy
(nor with the actual or the previous version).

I tested:
old -> new (secure)
new -> new (secure)
new -> new (unsecure)
new -> old (unsecure)

new -> old secure *won't* work, and I see really no reason to hack this in,
use unsecure migration if you put yourself in a situation where this is needed.
(Or just update the old node first :) )

cheers,
Thomas

Thomas Lamprecht (3):
  migrate: collect migration tunnel child process
  migrate: use ssh forwarded UNIX socket tunnel
  migrate: add some more log output

 PVE/QemuMigrate.pm | 158 ++++++++++++++++++++++++++++++++++++-----------------
 PVE/QemuServer.pm  |  10 ++++
 2 files changed, 119 insertions(+), 49 deletions(-)

-- 
2.1.4




More information about the pve-devel mailing list