Mainboards

From Proxmox VE
Jump to: navigation, search

Introduction

This Mainboard / Motherboard compatibility list for Proxmox VE is work in progress and is never complete. Everybody is encouraged to add working configurations - do not forget to add the used Proxmox VE kernel version (2.6.18/2.6.24/2.6.32).

Brands

Intel

ASUS

  • M4A78T-E (2.6.24) onboard NIC does not work
  • M3A78 AMI ACPI BIOS 1606, CPU AMD Athlon 64 X2 Dual Core Processor 4200+ works with 2.6.24-2-pve but no with more recent (even with 2.6.24-5-pve hangs at boot time)
  • M3A78-EM, Phenom II X4 920 Processor, 1.2 and 1.3 hangs at boot time, not tried 1.4
  • M3A, AMD Phenom 9550 processor, works with 1.3 (not tried with 1.4, don't remember about previous versions of Proxmox)
  • P5KPL-VM - Intel G31 Platform - with E7500 CPU (SLGTE) works fine on Proxmox VE 1.7 defaults
  • P7P55D Deluxe works fine
  • P7P55D Pro works fine with pve-manager/1.5/4822 and kernel: 2.6.18-2-pve
  • M4A89TD PRO/USB3 + AMD X6 1055T works fine with pve-manager/1.6/5087 kernel: 2.6.32-4-pve
  • M5A88-M works perfectly. Had to change the BIOS setting to enable 'Secure Virtual Machine mode' (disabled by default) in order to have it recognize 64 bit support, and for KVM installation. Once this was done, works great and very fast. Onboard NIC is fine and fully supported by Proxmox VE. NOTE: Onboard RAID support is NOT recognized by Proxmox VE. Needs to have a decent RAID adapter. I got mine working with HP LSI SAS3041E-HP card.
  • M5A78L-M/USB3 works fine as of June 2013 with AMD FX-8350 CPU, motherboard BIOS 1503, and Proxmox 3.0. (i.e., 2.6.32-20-pve) Be sure to enable Secure Virtual Machine mode in BIOS.
  • P9X79 PRO works fine as of October 2013 with Intel i7-4930K CPU, motherboard BIOS 4302, and Proxmox 3.1. (i.e., 2.6.32-24-pve)
  • P9D-MV works fine in our Proxmox Testlap
  • Z97-A all working

Gigabyte

  • GA-G33M-S2L (2.6.24/2.6.32), everything works out of the box.
  • GA-EP45-UD3L - Use on BIOS vF4 - The BIOS vF7 causes ACPI errors and does not boot
  • GA-MA770 UD3 rev 2.0 - BIOS FG causes kernel panic on copy large files (> 5GB) to server (AMD Athlon 5050e, 160GB SATA, 8GB RAM)
  • GA-EP35C-DS3R Using BIOS F4

SuperMicro

  • X8STE (2.6.18), all components working ("cluster-proof")
  • X8ST3-F (2.6.32), all components working (Latest BIOS)
  • X7SBE (2.6.32-3-pve), all components working (cluster, DRBD storage, software RAID0)
  • X8SIL-F (2.6.18), all components working
  • X10SRi-F works perfect as cluster in our testlab
  • X10SLM-F everything is working

DELL

  • 0K399H ver. A02 of PowerEdge R610 with 2x Xeon L5520 (2.6.32); 3 node cluster
  • PowerEdge 2650 fails to boot ProxMox using PERC 4 RAID controller.
  • PowerEdge 1850 & 2850 work out of the box.
  • PowerEdge 1950 & 2950 work flawlessly out of the box. Make sure to enable Intel-VT support in BIOS. Default Perc 5/i RAID is fully recognized by PM VE
  • PowerEdge R720 & R730 work out of the box.
  • PowerEdge R905 works out of the box. Uses PERC 6/i SAS RAID. Use 4.2.1 BIOS, 1.06 backplane and latest PERC 6/i firmware.

HP

  • Proliant DL385 G5. Works well. Uses either P400 or P400i RAID controllers.
  • Proliant ML570 G2. Fails on bootup of ProxMox. Server works great using RHEL-based and FreeBSD, however.
  • Proliant DL360 G3. Fails on bootup of ProxMox with kernel panic.

MSI

ZOTAC

  • ZOTAC ZBOX ID90 works well as of August 2015 with Intel i7-3770T CPU, motherboard BIOS 4.6.5, and Proxmox 3.4. (i.e., 2.6.32-39-pve)